Lumo Lift App Compatibility

Compatible with Android phones (excluding tablets) running 5.0 or later.

Compatible with iPhone SE, 5S, 6 or newer.
(iOS 11.3 or above)

Android App on Google Play Badge
Download on the App Store

Still need help?
Visit our Support Page